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Xilinx Project Navigator Reference Guide

Author: David M. Sendek

Background: This guide provides you with step-by-step procedures in using the Xilinx
Project Navigator to perform the following:
e Synthesize your Very High speed Integrated Circuit Hardware Description
Language (VHDL) code to a netlist
e Map, place and route your netlist onto a Spartan II FPGA (which is used on the
XESS XSA-50 Field Programmable Gate Array (FPGA) protoboard
e Map Input/Output (I/O) pins to devices on the XESS XSA-50 FPGA protoboard.
e Generate a bit stream so the design can be downloaded onto the Spartan II
FPGA residing on the XESS XSA-50 FPGA protoboard.
¢ Finally, although the downloading utility is NOT apart of the Xilinx Project
Navigator, the steps to download the design are also provided here.

Assumption: Students have a basic understanding of Windows

Procedures:

1. To Start the Xilinx Project Navigator,
Start > Engineering Applications > Xilinx ISE 5 > Project Navigator
or using the following icon:

Praoject
Mavigator

2. After starting the Xilinx Project Navigator, the following screen will be displayed:
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3. You must create a new project, if you have not done this step before. From the
Xilinx Project Navigator main menu select File > New Project. The window displayed
below will be displayed. You must enter a new project name. In this case, “test” was
used. The Device Family, Device, Package used for the XESS XSA-50 FPGA
protoboard is provided. The speed grade characterizes the type of performance you
require. You can opt for a speed grade of —5 (standard performance or speed grade —6
(higher performance). Speed grade —5 should suffice. For the Design Flow, if using
VHDL as your source, select XST VHDL from the pull-down menu or if using Verilog as
your source, select XST Verilog from the pull-down menu. Press OK.

New Project §|

Project Mame: Project Location:
|tesﬂ |E:'¢<ilin:-:'\test

Project Device Optians:

Property Name Value |
Device Family Spartan2
Device xc2s50
Package tq144
Speed Grade -5
Design Flow KST WVHDL

ak | Cancel Help ‘

4. After you have completed step 3, the following screen will be display with your
device in the upper left hand corner of “Sources in Project” Window.
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5. At this point you should make sure your already compiled and simulated VHDL
source code is located in the directory you created in step 3. Next you need to add your
source code to the project. In the “Sources in Project” window, left click on the line
where XC2s50 —5tq144-XST VHDL (or XC2s50 —6tq144-XST) is located to highlight
that entry. Using the pull-down menu (or alternatively the right mouse click) select
Project > Add Source. Now enter your source code through the “Add Existing Sources”
window by highlighting the desired source code and pressing “Open”. Note if you are
using a hierarchical design, enter the high level module first. You may be asked to
clarify what is the source via the “Choose Source Type” window. Make sure VHDL
Module is highlighted and press OK.

Add Existing Sources

Lookin: | £ test I = s

wH|counter

;_ﬁ]cnunter?segment

[ yilleddcd

File name: I Cpen
Files of type: ISnun::es {"_t:d;‘.'n.rhd;‘.sch;‘.tbw;‘.bmm;‘.eﬁ;‘.lj Cancel |
Choose Source Type K|

counter fzegment. vhd iz which zource twpe?

The =uffix iz ambiguous az to type.

VHOL M odule 0k,

YWHOL Package 4'

WHOL Test Bench Cancel |

Help |

6. Xilinx Project Navigator will load your design and the windows will look

something similar to what is illustrated below. It should be noted that the example used
in this tutorial is a hierarchical design. It has an ARCHITECTURE block with two
components (counter & ledded). The high-level ARCHITECTURE is defined in the file
counter7segment.vhd. If using a hierarchical design, the other files must be added.
Repeat step 5, but highlight each component to load its associated VHDL file. If you
successfully complete this action, there will be “check” marks to the left of your design
name(s)



Sources in Project: |
[ test
= £ xc2s50-6g144 - X5T VHOL

& [] counterTsegment (courter7segment vhd)

" oguie View | (0 Snapshot View | () Livery View |

1=
Processes for Curent Source: I;
= gF Design Entry Ltities

~-¥3%  Create Schematic Symbal

.| Launch ModelSim Simulator

iew Command Line Log File
~~[2]  View VHDL Instartiztion Template
= W |User Constraints

e ] Create Timing Constraints

-~ Assign Package Pins

o ] Create Area Constraints

.| Edit Constraints (Text)

S Synthesize

View Synthesis Report

- View RTL Schematic

%% Analyze Hierarchy

~-¥3 Check Syntax

=3 Implemert Design

----- T Trnslkte -
1 | ’

] 'ﬂﬁmﬂ‘i&wl

x| JHDFARSE — VHDL-Verilog Parser.
E ISE 5.1i Copyright (c) 1995-2002 Hilinx, Inc. All rights reserwved.

Scanning counter?segnent . vhd
Scanning counter?szegnent . vhd
Writing counter?segnent . jhd.

JHDFPARSE complete — 0 errors, 0 warnings.

> ™ 1

7. Now you are ready to synthesize your design to make a netlist. To begin with the
options of the “Processes for Current Source Window” is provided below.



Sources in Project:

B test

=€ wcPshl-igl144 - ¥5T VHDL
- @ counter fsegment (counter /segment vhd)
@ counter (courter vhd)
@ leddcd {eddcd vhd)

IS Module View I DN Snapshot View @ Library View

Processes for Cument Source:
- W Design Entry Ltilties
3 Create Schematic Symbol
0 Lsunch ModelSim Simulator
View Command Line Log File
View VHDL Instantiation Template
- W User Constraints
[0 Create Timing Constrairts
0  Assign Package Pins
0  Create frea Constraints
[0  Edt Constraints (Text)
-3 Synthesize
View Synthesis Report
0  View RTL Schematic
G Analyze Hierarchy
3 Check Syrtax
- G Implemert Design
+--3 Translate
3 Map
---¥3  Place & Route
Place & Route Report
Asynchronous Delay Report
Pad Report
Guide Results Report
- ¥ Generate Post-Place & Route Static Timing
0 Post-Place & Route Static Timing Report
Text-based Post-Place & Route Static Timing Report
0 Analyze Post-Place & Route Static Timing (Timing Analyzer)
0 View,/Edit Placed Design (FloorPlanner)
0  Analyze Power ($Power)
3 Gerersts Post-Place & Foute Simulation Modsl
3 Gerersts IBIS Model
3 Multi Pass Place & Route
---¥3  Back-annotate Fin Locations
Back-annotate Pin Report
View Locked Pin Constraints
- G Generate Programming File
Programming File Generation Report
0 Generste PROM, ACE, or JTAG File
0 Corfigure Device (MPACT)



To synthesize your design, double left click on “Synthesize” in the “Processes for Current
Source:” window or right click on “Synthesize” and select “Run” or “Rerun” (the latter
instructions will depend on whether or not you have selected to synthesize your design on
an earlier occasion). The following will result:

—

Processes for Cumrent Source: I:
- W Design Entry Ltilties
3 Create Schematic Symbol
]  Leunch ModelSim Simulator
@# View Command Line Log File
View WHOL Instantiation Template
- W Izer Constraints
1  Create Timing Constraints
1  Assign Package Pins
E]  Create frea Constraints
O]  Edit Constraints (Text)
- ¥ 3a# Synthesize
@# View Syrthesis Report
1  View RTL Schematic
T3 Analyze Hisrarchy
T3 Check Syrtax
- G Implement Design _

O Trenslate
S Mep
---¥%  Place & Routs
Place & Route Report
Asynchronous Delay Report
Pad Report
Guide Results Report
-3  Generate Post-Place & Route Static Timing

£ Post-Place & Route Static Timing Report
= Text-based Post-Place & Route Static Timing Report 2

B2 Process View

LZIX

Clock Information:

Ho clock =ignals found in this design

Timing Summary:

Speed Grade: -6

Minimum periocd: Ho path found

Minimum input arrival time before cloclk: Ho path found
Maximum output required time after clock: Ho path found
Mamimum combinational path delay: 8.783n=s

Completed process "Synthesize".




7. Now you are ready to route, place and map your netlist onto a Spartan Il FPGA
(which is used on the XESS XSA-50 FPGA protoboard). To route, place and map your
design, double left click on “Implement Design” in the “Processes for Current Source:”
window or right click on “Implement Design” and select “Run” or “Rerun” (the latter
instructions will depend on whether or not you have selected to route, place and map your
design on an earlier occasion). The following will result:

Processes for Cument Source: I;l
e Analyze Hierarchy
o3 Check Syntax
=¥ 3@ Implement Design
-3 Translate
- Map
= 3g# Place & Route
------- @ Place & Routs Report
------- @ Asynchronous Delay Report
- Pad Report
------- Guide Results Report
=¥ 3p#? Generate Post-Flace & Route Static Timing
- 0 Post-Place & Route Static Timing Report
@# Text-based Post-Flace & Route Static Timing Report
5] Analyze Post-Place & Route Static Timing (Timing Analyzer)
Wiew/Edit Placed Design (FloorFlanner)
Analyze Power [¥Power)
Generate Post-Flace & Route Simulation Model
Generate 1BIS Model
Multi Pass Place & Route
Back-annotate Pin Locations
] Back-annotate Pin Report
View Locked Pin Constraints

GOOGO

Programming File Generation Report
- Generate PROM, ACE. or JTAG File T
“-[1  Corfigure Device iMPACT) ﬂ

] .ﬁPrms‘.liewI

fll Started proces= "Generate Pos=t-FPlace & Route Static Timing" .
*

Loading device database for application trce.exe from file "leddcd. ncd".

"leddcd" is an HCD, wversion 2.37. device zcdstl, package tgld4, spesd -6
Loading device for application trce.exe from file 'w50 . nph' in environment
Cor¥ilin=.

Analy=zis completed Sat Jul 19 13:15:00 2003

Generating Eeport

Completed process "Generate Post-FPlace & Route Static Timing".

Flace & Route Module ledded . . .
PAR command line: par —w —ol 2 —t 1 leddcd_map.ncd ledded ncd ledded  pof
FAR completed =successfully

¢ i |



8. Before you generate your bit stream to download onto the FPGA, you must first define
your I/O to be used on the XESS XSA-50 FPGA protoboard. The pin definitions for
various I/O devices used in EE451 can be found in the EE451 website under Tips >
XESS Corporation FPGA Protoboard > I/O Pin Mappings. In this particular example, we
will define the clock input and outputs to a 7-segment display. First we must attach an
implementation or user constraints file (or *.ucf file) to the XC2s50 —5tq144-XST VHDL
(or XC2s50 —6tq144-XST) definition of the FPGA. To do this, highlight the XC2s50 —
5tq144-XST VHDL (or XC2s50 —6tq144-XST) in the “Sources in Project:” window.
Using the pull-down menu (or alternatively the right mouse click) select Project > New
Source. A “New” window will be displayed as illustrated below. Highlight the
“Implementation Constraints File” entry and enter a name of your implementation
constraints file. Press “Next”.

New X

IUser Document
VHOL Module
Schematic
WHOL Librany ;
VHDL Package i e
WHOL Test Bench !Tseg_mappings
Test Bench Waveform
BMM File
MEM File Location:
lementation Constraints File 2
State Diagram !C:‘a}ﬁllrm‘\:test
¥ Add to project
< Back Mext > Cancel Help




In a hierarchical design, select you top-level source code filename as illustrated below
and press “Next”.

Select E3
’ﬁsﬁodateﬁﬂ'l Source
leddcd
counter

courter /segment

< Back Meadt = Cancel Help

The following screen will be displayed. Simply press “Finish”.

New Source Information | X |

Project Mavigator will create a new skeleton source with the
following specifications:

Source Type: Implementation Constraints File
Source Mame: 7seq_mappings uch
Association: counter7segment

Source Directony: C:oiliretest

< Back Firish Cancel Help




In the “Sources in Project:” window the *.ucf file is now added to your design.

Sources in Project:
B test
= £33 xc2sh0-htg144 - X5T VHDL
- @ counter/segment (counter /seament vhd)
@ 7seg_mappings uct
E counter (counter vhd)
E leddcd (leddcd vhd)

Make sure you highlight your top-level design in the “Sources in Project:” window. In
the “Processes For Current Sources:” window, double click on the following application:
User Constraints > Create Timing Constraints. The “Xilinx Constraints Editor” Window
will be displayed. Ensure you have the “Ports” tab selected. You can enter the I/O
to/from your FPGA as being used on the XESS XSA-50 FPGA protoboard. Ensure you
enter a “P” for pin before each pin number. The results are shown below. Make sure you
save the mappings to the *.ucf file that you just created for possible future use. In the
“Xilinx Constraints Editor” pull-down menu, select File > Save. If you use this file in the
future, you do not need to create it as in step 8. All you do is “add” the *.ucf file to your
design. Additionally, since the route, place and map procedures done in step 7 mapped
I/O without a user constraints file, you may have to repeat step 7 with the user constraints
file that you just created.

10



wli Xilinx Constraints Editor - [Ports - counter /segment.ngd / 7seg_mappings.ucf*]

File Edit ‘iew ‘Window Help
Ofe(@| x| =[={0lo| 2|
Port Name Port Direction Location Pad to Setup Clock to Pad
clk INPUT P28 MNIA NJA
z=l= QUTPUT PsY N/A,
sl QUTPUT P39 MNIA,
gads QUTPUT P52 NIA,
2<3= OUTPUT Ps0 MNJA,
sed= OUTPUT P46 NiA
g=5> OUTPUT PS7 MNJA,
g<f> OUTPUT Pag NJA
~Pad Group
[~ 1/0 Corfiguration Options Group Name: I Create Group I
o . FPad to Setup... |
Brohibit 140 Locations... Select Group: | = I
Clock ta Pad... I
Global Ports I Advanced I Misc |
NET "dk”™LOC = "P38%;
NET "s<0="LOC = "P&7;
NET "s<1="LOC = "P39%
NET "s<2>"LOC = "P62%
MET "s<3>"LOC = "P&0%;
MET "s<4>"LOC = "P46%;
MET "s<5>"LOC = P57
MET "s<6>"LOC = P497
UCF Conctraints (read-write) |UCF Consrainiz (read-only) Seurce Concramiz (read-only)
|For Help, press F1 | ,z’l

9. Now you are ready to create the bit stream to be downloaded to the XESS XSA-50
FPGA protoboard. Ensure your design is selected in the “Sources in Project:” window.
In the “Processes for Current Source:” window, double left click on “Generate
Programming File” or right click on “Generate Programming File” and select “Run” or
“Rerun” (the latter instructions will depend on whether or not you have selected to create
a bit stream on an earlier occasion). The following will result:
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Sources in Project:

B test

—- £ xc2sh-Btq144 - XST VHDL
- @ counter fsegment (counter 7segment vhd)
@ 7seg_mappings.ucf
@ counter {courter vhd)
[¥] ledded Jedded vhd)

B Module View ‘ I8 Snapshot View E Library View

Processes for Cumrent Source:

@# View Syrthesis Report
08  View RTL Schematic
3@ Analyze Hierarchy
Tap# Check Syrtax
- ¥ 3a# Implemert Design
+ -3 Translate
+ - Tie# Map
=3 Place & Route
@” Place & Routs Report
[E1@# Asynchronous Delay Report
Pad Report
Guide Results Report
@’ Generate Post-Place & Route Static Timing
8 Post-Flace & Route Static Timing Report
@” Text-based Post-Place & Route Static Timing Report
8 Analyze Post-Flace & Route Static Timing (Timing Analyzer)
View/Edit Placed Design (FoorPlanner)
Analyze Power [(¥Power)
Generate Post-Place & Route Simulation Model
Generate 1BIS Model
Mutti Pass Place & Route
Back-annotate Pin Locations
Back-annotate Pin Report
View Locked Pin Constraints
-1 ¥ 3@ Generste Programming Fil
(y” Programming File Generation Report
B  Generste PROM, ACE, or JTAG File
0]  Configure Device (MPACT)

%

OGO

B Process View

=
H Sat Jul 19 14:27:16 2003

Funning DRC.

DRC detected 0 errors and 0 warnings.
Creating bit map. ..

Saving bit stream in "counter?segment bit".
Bit=tream generation is complete.

Completed process "Generate Programming File".
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10. Now you are ready to download your bit stream onto the XESS XSA-50 FPGA
protoboard. To accomplish this, we must use the XESS GXSLOAD utility. The utility
can be found in
Start > Engineering Applications > XESS > GXSLOAD

or using the following icon:

The following application will be started for download. Use the “My Computer”
windows feature to go to the subdirectory where your subdirectory you created in step 3
is located. Simply drag the *.bit file into the FPGA/CPLD of the GXSLOAD utility.
Now press “Load”. The bit stream will be downloaded onto the XESS XSA-50 FPGA
protoboard.

[ gt AEET HES
o
Bioard Type  [XGA50 = g oL
Port LPT1 - Eit Q Back ~ () ? / ! Search Folders Elv
Address |IC3 C:Wilinx\test v Go | MNorton AntiVirus -
RiM Flash/EEPROM . C: e : 1> 5
= A Name Size  Type Da
= _ s L
File and Folder Tasks % counter?segment 3KB MTI vhdl 7M1
Lk
- counter7segment.ana OKB AMA File 71
®[} Rename this file b
__ ) counter 7segment.bgn 6KB BGN File 71
T [y Move this file counterFsegment. bit 63KB BITFile 71
9 | | [ Copy this file [# counter7segment.bid 1KE BLD File 71
Low Address | | @ Publish this file to the @ counter7segment.cmd_log 2KB CMD_LOG File 71
\Web @ counter 7segment.dly 7KB DLY File 71
Ll B, :" [ |HEX :‘v ] () E-mail this file @ counter 7segment.drc 1KB DRCFie T8
3¢ Delete this fle i~s >

11. Now you can demonstrate that your design is properly working.

Helpful Tools Associated with Xilinx Project Navigator:

In the “Processes for Current Source:” window there are some utilities and reports that
can help you with your design.

1. To observe where your signals were mapped onto the FPGA, your can look at the
PAD Report. This can be found at Implement Design > Place & Route > Pad Report

2. Once your constraints file is created, instead of using the Xilinx Constraints
Editor, you can simply edit the results. This can be done by executing User Constraints >
Edit Constraints (Text) or you can go back to the Xilinx Constraints Editor by executing
User Constraints > Create Timing Constraints
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