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Background:  Mentor Graphics DA is a schematic capturing Computer Aided Design 
(CAD) tool for use with digital logic gates and/or analog components.  QuickSim is 
Mentor Graphics’ digital simulator.  The circuit is simulated by forcing input values and 
then observing the results graphically.  This handout is intended as an introduction to DA 
& QuickSim II.  Through experimentation, trail-and-error or reading the Mentor 
Graphics Manuals, your ability will expand with this CAD tool. 
 
References:   (a)  “Using Mentor Graphics for Digital Simulation”, David M. Zar, 

       9/1/97,  http://ge.ee.wustl.edu/dzar/tutorials/digital 
(b) “Force File and Force Commands”, David M. Sendek, 9 July 2003 

 
Assumptions: 

1. Student has an account on the engr server 
Note:  If not, student must go to Anderson Lab in Glover to create an account. 

2. Student knows how to sign-on the engr server. 
3. Student knows how to go from a Windows to Unix environment. 
4. Student has basic understanding of Windows OS and Unix commands. 

 
SETTING UNIX ENVIRONMENT FOR DA & QuickSim (steps at the Unix prompt) 

1. Create a directory ee451, if one does not already exist 
2. Create a sub-directory for each lab, ex: lab2, lab3, … 
3. Create sub-directories under each lab, as appropriate. 
4. %setenv MGC_WD $HOME/path 

ex:  %setenv MGC_WD $HOME/ee451 
5. Change to your working ee451 sub-directory 
6. %source /mentor/csu_setup/idea_setup.csu 
Notes:  
            -     There is a space between %source and /mentor…  

- This permits you to gain access to both DA & Quicksim 
- If you do not modify your .cshrc file, you must repeat steps 3 through 

5 each time you re-open your unix window. 
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FEATURES OF DA 
STARTING & EXITING DA 

1. Starting DA: 
-  At Unix prompt, enter    %da 
-  Once da has launched, maximize the screen.  Clicking on the  
    “large block” in your upper right hand screen.  

  2.   Exiting DA:   select MGC > Exit 
  **** Note:  To drill-down a menu select the “Right Arrow” must be  

        selected (left mouse click) 
 

CREATING, OPENING,  SAVING AND CHECKING A  (DESIGN) SHEET 
1. Creating a Sheet (steps): 

-  In the “session_palette” window click on the icon “OPEN SHEET”. 
-  Click OK. 
Note: Your default sheet will be sheet1 

2. Opening a Sheet (steps): 
-  Under the “session_palette” window, click on the icon “OPEN 
   SHEET”. 
-  In the “Open Sheet” pop-up screen, click Navigator … 
-  In the “Component, Schematic, or Sheet” pop-up screen, click on  
   the Component Name you provided when you first saved the circuit  
   diagram. 
-  In “Open Sheet” window, select OK 

            3.   Checking your Design (steps): 
-  In the “Design Architect” window, Check > Sheet > With Defaults 
    Notes:   

• Checking your sheet ensures that you produce a valid, 
workable circuit. 

• You will not be able to save and use the logic as a symbol, if 
you do not check the sheet. 

• To find the location of errors or warnings:  Select Edit > 
Select > By handle.  The “Select By Handle” pop-up 
window will be displayed.  Enter the handle/signal name.  
ex:  N$9 

4.   Saving a sheet (steps): 
-  Select File > Save Sheet as 
-  At the “Save Sheet As” screen, in the “Component Name” entry, add  
    the name of your circuit diagram. 
-  In pop-up “Save Sheet As” screen, enter sheet name: 
    Ex: sheet1, sheet2 … (sheet1 is your default name) 
-  Click OK 

      
      *** Note:  Each sheet should be in its own subdirectory 
                        EX:  …/ee451/lab2/1bit 
                                …/ee451/lab2/3bit 

           *****  Make sure you save your design in the directory you want it in ***** 
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SELECTING A COMPONENT LIBRARY (steps) 
1. In the “session_palette” window, click on the icon “LIBRARY” 
2. Select, gen_lib  (this is the library we will be using in EE451).  

Another useful library is the Generic_Lib.  This can be used by 
selecting Libraries > MGC Analog Libraries > Display Libraries 
Palette.  In the MGC Analog Libraries window, select Generic_lib 

3. If a scroll bar is not present with the gen_lib, place the mouse arrow 
over the gen_lib.  On the mouse, hold and right click.  Select “Show 
Scroll Bar” 

4. Now you are ready to start adding components to your sheet. 
 

ADD & DELETING LOGIC SYMBOLS AND COMPONENTS 
1. Adding Components: 

-  In “gen_lib” window, select the various gates required for your  
    circuit design. 

      -  The symbol selected will be displayed in the window above  
          the “gen_lib” window. 
      -  A portin, portout or portbi components for I/O terminations are  
         found in gen_lib. 
      -  There may be a need for transistors or ground signals.  These can be 
          found in the analog library. 
      Notes: 
 -  Use your mouse to drag the symbol to your desired location. 

      -  Use the left mouse button to set into position the logic symbol 
2. Deleting Components: 

-  With the left mouse button, select the symbol 
-  The symbol(s) to be deleted will now be drawn in dashed-lines 

      -  Click the right mouse button.  The “Instance” pop-up window will 
    be displayed.  Select “Delete” 

                             Notes:  After every add or delete, the symbol selection list needs to be 
                                          cleared.  Use F2 to unselect the object so that another symbol  

      can be added/deleted. 
 

ADDING & DELETING WIRES 
1. To add a wire (steps & notes): 

-  Ensure the “session_palette” window is displayed.  In the “Design  
   Architect” window, select Libraries > Display Schematic Palette 
-  In the “session_palette” window, click on the icon “ADD WIRE”. 
-  Shortcut:  F3 
Notes:   

-  Left mouse click at the starting point 
-  Left click on the mouse, to create vertices, if required. 
-  End wire connection by double-clicking on the left mouse.   
   This can also create a connection point. 
-  To get out of the “ADD WIRE” mode, click Cancel in the “ADD  

          WIRE” pop-up window. 
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2. To delete a wire (steps): 
-  Use F2 to unselect wires/nets & logic 
-  With the left mouse button, select the wire 
-  The wire(s) to be deleted will now be drawn in dashed-lines 

      -  Click the right mouse button.  The “Net” pop-up window will 
    be displayed.  Select “Delete” 

3. To automatically connect wires (steps) 
- Select the wire 
- Shortcut: ctrl + F6 

 
TO UNDO THE LAST COMMAND (In the “Design Architect” window) 
      -  select, Edit >Undo 

 
ZOOM IN/OUT (In the “Design Architect” window) 
 1.  Zoom In:     select View > Zoom In > selectparameter 
                 Shortcut: + 
 2.  Zoom Out:  select View > Zoom Out > selectparameter 
                 Shortcut: - 

 
ADDING & DELETING LABELS 

  1.   Add a portin or portout symbol to your wire. 
2.   To add a label:   
- Select the portin or portout symbol 
- Place the mouse pointer over the text “NET” 
- Select shift+F7 
- Enter the name desired in the new value box in lieu of the name 

“NET” 
To delete a label : 

- Select the port. (left mouse click) 
- Right mouse click.  Select delete 

 
ADDING & MODIFYING INPUT/OUTPUT PORTS (NETS) 
 1.  Select the port you want to Name (left mouse click) 
 2.  In the “Design Architect” window, select NET > Name  

 
PRINTING SCHEMATICS 

Select file > Print Sheet:  Enter mentor_c207 as the printer name. 
 

MAKING A “SYMBOL” 
 Background:  A symbol permits you to group logic gates into a single 
            symbol.  The symbol then can be used in a subsequent sheet.  This creates 
            a hierarchical structure to your drawings.  As an example:  With a 3-bit 

Arithmetic Logic Unit (ALU) in lab 2, you can develop a 1-bit slice ALU.  
Then a symbol is created using the 1-bit slice ALU logic.  In a subsequent 
sheet, three 1-bit slices (the symbol created) are then wired together. 
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 *** Caution:  To avoid problems, no more than one sheet and 1 symbol 
           should be in a directory.  You must control where the sheet and symbol is 
           saved.  Don’t assume Mentor Graphics is handling this properly.  This will  
           require a directory tree structure for each lab.  It is recommended that you 
           use “save as” instead of “save” to ensure the file (the sheet or symbol) is  
           saved in the proper directory. 
 

1. Check the sheet prior to creating a symbol 
2. In DA, select MISC > Generate Symbol 

-  Select Sort Pins      Yes 
-  Click OK 
Notes: Do not make any additional changes to the “Generate Symbol” 
pop-up window. 

3. In DA, select check > With Defaults 
4. In DA, select File > Save Symbol > Default Registration 
5. Open a new sheet 
6. “Choose Symbol” icon to pull-in the symbol created 

 
MAKING A NET (“Bus” or “Bundle”) 

1. Ensure you label your portin, portout or portbi like “A[2:0]”, 
representing 3-bits 

2. To “add” a net in DA,  
      select miscellaneous > General Symbol 

select Yes for “Sort pins” 
3. To “break-out” a signal from a bus: 

- Draw a wire 
- Once completed with the wire, the pop-up window “Choose Bus 
      Bit” will be displayed. 
- Enter the bit you want to tap-off. 

4. To add a bus, 
In “schematic_add_route” window, select icon “ADD 
BUS/BUNDLE” 
 
 

SIMULATING YOUR DIGITAL DESIGN 
 
STARTING & EXITING QUICKSIM 

1. You need to be in a directory level above where your design directory 
is located.  Note:  If you use the default name “sheet1”, your design 
name is the name of the directory where the folder “schematic” 
resides. So if your “schematic” sub-directory is say in the “lab2” 
directory, you need to be in the directory level that contains the “lab2” 
sub-directory. 
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2. Starting Quicksim: 
-  In Unix,    %quicksim designname 
    Note:  This assumes you are in same directory as your designname 
-  Once quicksim has launched, maximize the screen.  Clicking on  
    the “large block” in your upper right hand screen.       

3. Quitting Quicksim: 
At the “QuickSim II”, select MGC > Exit 

 
 OPENING A SCHEMATIC DESIGN  

- In the “Setup” window of Quicksim II, select the “OPEN 
SHEET” icon.  

- After selection, your schematic should be displayed. 
- Maximize the screen.  Clicking on  the “large block” in your 

upper right hand screen. 
 
SIMULATING YOUR DESIGN 

  
  Discussion:   First, you need to specify the input signals. Mentor  

Graphics calls this a force. You need to specify which  
signal is to be ``forced.'' You do this by selecting the signal,  
on your schematic, with your mouse. Simply click on the A  
port in your schematic. You should see the wire turn white  
denoting that it is selected.  Reference (a).  Some force 
commands can be found in reference (b). 

 
1. Using a Force File (Recommended Approach) 

-  Select signals (to trace on your design sheet) 
      -  Select “TRACE” in “Stimulus” window 
      -  In the “TRACE” window, right click the mouse 
      -  In the “QuickSim” pop-up window, select 

    Force > From File      Enter the forcefilename 
 

2. Manually Forcing an Input (steps) 
-  At the “Setup” window in QuickSim II, select the “STIMULUS” 

          button. 
      -  On the schematic, select the input desiring to “force”.  Note that the 
          input path will be dashed and in white.  
      -  In the “Stimulus” window, select the “ADD FORCE” icon 
      -  Input the Value & Time pairs.  Press OK. 
      -  Repeat with the next input signal (if any) 
 
3. Displaying the Trace Window 

-  Select all signals desiring to be traced.  (using left mouse click) 
      -  At the “Setup” window in QuickSim II, select the “TRACE” 
          button. 
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4. Opening a List Window 
-  At the “Setup” window in QuickSim II, select the “LIST” 
    button. 
 

5. Running the Simulation 
-  Click on the “List” window 

      -  Start typing “run xx” (where xx is the number of nanoseconds to be 
    simulated). 
-  Hit return 
-  The “Trace” and “List” windows will display the results of the  

          simulation. 
 
6. Clearing the Simulation 

-  in the “Design Changes Window”, select “reset” and then select 
    “state” only.  Enter OK. 
 

7. Print Out Simulation 
-   Select the desired window to be printed.  
-   Select File > Print.  Enter mentor_c207 as the printer name. 

 
  Comments: 

- In the “Stimulus” window of QuickSim II, it provides you with 
the capabilities to “ADD CLOCK” and “FORCE TO STATE” 
as additional icons that can be used in the simulation. 

- A print work-around is to “screen capture” your results.  This is 
done by pressing “shift-PrtScn”.  Then using MS Paint or MS 
Word applications, the screen capture can be “pasted” into the 
application.  Finally, using the application print command, the 
simulation can be printed from Windows. 
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